Soru Excelde ana bir sayfadan birçok sayfaya veri aktarımı nasıl yapabilirim

ozded

New member
Üye
#1
Merhaba size örnek çalışmam olarak attığım excelde ana sayfada 480 e yakın etken madde listesi var hepsinin yanına değer ekleye ekleye gideceğim yani herseferinde aynı satırdaki aynı etken madde için farklı bir sütuna değer girmiş olucam ve bu listede yer alan her etken madde için bir sayfa var. Ana sayfaya her veri grdiğimde o etken maddeye ait sayfada e sütununa o veriyi aktarmasını istiyorum bu seferde satır değişken oluyor. İç içe döngü falan denedim ama bir türlü işin içinden çıkamadım yardımcı olursanız çok sevinirim. Örnek dosyayı ekte paylaşıyorum şimdiden teşekkürler...
 

Ekli dosyalar

alperduryaz

New member
Üye
#4
Kod:
=İNDİS(Sayfa1!A:Q;KAÇINCI(PARÇAAL(HÜCRE("dosyaadı";A1);BUL("]";HÜCRE("dosyaadı";A1))+1;255);Sayfa1!A:A);SATIR(E34)-30)
Yukarıdaki formül ile sorunu çözebilirsiniz. Bu kodu E34 'e yazıp aşağı doğru çekip deneyin eğer istediğiniz sonucu alırsanız hiç değiştirmeden her sayfada E34'e yazıp aşağıya doğru çekmeniz lazım.
 

ozded

New member
Üye
#5
Kod:
=İNDİS(Sayfa1!A:Q;KAÇINCI(PARÇAAL(HÜCRE("dosyaadı";A1);BUL("]";HÜCRE("dosyaadı";A1))+1;255);Sayfa1!A:A);SATIR(E34)-30)
Yukarıdaki formül ile sorunu çözebilirsiniz. Bu kodu E34 'e yazıp aşağı doğru çekip deneyin eğer istediğiniz sonucu alırsanız hiç değiştirmeden her sayfada E34'e yazıp aşağıya doğru çekmeniz lazım.
Çok teşekkür ederim ilginiz için hemen deniyorum
 

ozded

New member
Üye
#6
Kod:
=İNDİS(Sayfa1!A:Q;KAÇINCI(PARÇAAL(HÜCRE("dosyaadı";A1);BUL("]";HÜCRE("dosyaadı";A1))+1;255);Sayfa1!A:A);SATIR(E34)-30)
Yukarıdaki formül ile sorunu çözebilirsiniz. Bu kodu E34 'e yazıp aşağı doğru çekip deneyin eğer istediğiniz sonucu alırsanız hiç değiştirmeden her sayfada E34'e yazıp aşağıya doğru çekmeniz lazım.
Bu formülü yazdığımda böyle bir uyarı verip en baştaki A:Q kısmındaki Q yu işaretliyor nerde işaret eksik anlamadım
 

Ekli dosyalar

Üst