Cevaplandı Excelde ana bir sayfadan birçok sayfaya veri aktarımı nasıl yapabilirim

ozded

Yeni Üye
Üye
Katılım
7 Kas 2018
Mesajlar
7
Tepki puanı
0
Puanları
1
Excel Versiyonu, Dili
Bilinmiyor
Merhaba size örnek çalışmam olarak attığım excelde ana sayfada 480 e yakın etken madde listesi var hepsinin yanına değer ekleye ekleye gideceğim yani herseferinde aynı satırdaki aynı etken madde için farklı bir sütuna değer girmiş olucam ve bu listede yer alan her etken madde için bir sayfa var. Ana sayfaya her veri grdiğimde o etken maddeye ait sayfada e sütununa o veriyi aktarmasını istiyorum bu seferde satır değişken oluyor. İç içe döngü falan denedim ama bir türlü işin içinden çıkamadım yardımcı olursanız çok sevinirim. Örnek dosyayı ekte paylaşıyorum şimdiden teşekkürler...
 

Ekli dosyalar

alperduryaz

Yeni Üye
Üye
Katılım
1 Eki 2018
Mesajlar
11
Tepki puanı
6
Puanları
3
Excel Versiyonu, Dili
Bilinmiyor
1. resimde kırmızı olan kısıma 2. resimdeki alandaki veriler mi gelecek?
2018-11-07_23-13-00.png

2018-11-07_23-12-25.png
 

ozded

Yeni Üye
Üye
Katılım
7 Kas 2018
Mesajlar
7
Tepki puanı
0
Puanları
1
Excel Versiyonu, Dili
Bilinmiyor
Evet hocam aynen o şekilde ,yapmaya çalışıyorum ama işin içinden çıkamadım
 

alperduryaz

Yeni Üye
Üye
Katılım
1 Eki 2018
Mesajlar
11
Tepki puanı
6
Puanları
3
Excel Versiyonu, Dili
Bilinmiyor
Kod:
=İNDİS(Sayfa1!A:Q;KAÇINCI(PARÇAAL(HÜCRE("dosyaadı";A1);BUL("]";HÜCRE("dosyaadı";A1))+1;255);Sayfa1!A:A);SATIR(E34)-30)
Yukarıdaki formül ile sorunu çözebilirsiniz. Bu kodu E34 'e yazıp aşağı doğru çekip deneyin eğer istediğiniz sonucu alırsanız hiç değiştirmeden her sayfada E34'e yazıp aşağıya doğru çekmeniz lazım.
 

ozded

Yeni Üye
Üye
Katılım
7 Kas 2018
Mesajlar
7
Tepki puanı
0
Puanları
1
Excel Versiyonu, Dili
Bilinmiyor
Kod:
=İNDİS(Sayfa1!A:Q;KAÇINCI(PARÇAAL(HÜCRE("dosyaadı";A1);BUL("]";HÜCRE("dosyaadı";A1))+1;255);Sayfa1!A:A);SATIR(E34)-30)
Yukarıdaki formül ile sorunu çözebilirsiniz. Bu kodu E34 'e yazıp aşağı doğru çekip deneyin eğer istediğiniz sonucu alırsanız hiç değiştirmeden her sayfada E34'e yazıp aşağıya doğru çekmeniz lazım.
Çok teşekkür ederim ilginiz için hemen deniyorum
 

ozded

Yeni Üye
Üye
Katılım
7 Kas 2018
Mesajlar
7
Tepki puanı
0
Puanları
1
Excel Versiyonu, Dili
Bilinmiyor
Kod:
=İNDİS(Sayfa1!A:Q;KAÇINCI(PARÇAAL(HÜCRE("dosyaadı";A1);BUL("]";HÜCRE("dosyaadı";A1))+1;255);Sayfa1!A:A);SATIR(E34)-30)
Yukarıdaki formül ile sorunu çözebilirsiniz. Bu kodu E34 'e yazıp aşağı doğru çekip deneyin eğer istediğiniz sonucu alırsanız hiç değiştirmeden her sayfada E34'e yazıp aşağıya doğru çekmeniz lazım.
Bu formülü yazdığımda böyle bir uyarı verip en baştaki A:Q kısmındaki Q yu işaretliyor nerde işaret eksik anlamadım

uyari.png
 

alperduryaz

Yeni Üye
Üye
Katılım
1 Eki 2018
Mesajlar
11
Tepki puanı
6
Puanları
3
Excel Versiyonu, Dili
Bilinmiyor
2018-11-09_11-27-00.png

Bende bir hata yok, hata olan kısmı silip elle o alanı seçmeyi dener misiniz.
 
Üst