Sitemize Hoşgeldiniz

Türkiye'nin en geniş özeliklere sahip forumu olan ExcelDestek.Com üzerinde soru sorabilmek, daha önceki sorulan sorulara, açılan konulara cevap yazabilmek, puan kazanabilmek, kazandığınız puanlar ile dosya indirebilmek ve çok daha fazla özellikten yararlanabilmek için sitemize üye olunuz.
Hemen Üye Ol ya da Giriş Yap

Sorun Cevaplayalım

Excel'e dair sorularınızı sorun, cevaplayalım.

Çözümlenmiş Sorular

Kullanıcılarımızın sorularını ve sunduğumuz çözümleri inceleyin.

Destek Ekibimiz Sizlerle

Ücretli destek ve özel hizmet talep edebilirsiniz.

Genel Excel Metin Biçiminde olan sayılar

Admin

Kurucu
Yönetici
Kurucu
SMS Onaylı
Katılım
1 Eki 2018
Mesajlar
863
Yaş
41
Web Sitesi
www.orkmes.com
Excel Versiyonu, Dili
Excel 2019 EN

Reputation:

Excel gelişmiş özelliklerine bağlı olarak, iş dünyasında kullanılan tüm programlara veri aktarma ve aynı programlara veri sağlama özelliğini sağlayan çok güçlü bir yazılımdır.
Kullanılan özel programların büyük bir çoğunluğu, oluşturulan raporların Excel'e aktarılmasını sağlar.
Excel gibi güçlü bir yazılım varken, sanırım kimse daha gelişmiş bir raporlama aracı tasarlamak ile uğraşmak istemez.

Ama bazı durumlarda, bu programlardan Excel'e aktarılan veriler, istediğimiz biçimlerde gelmezler (ben iş bilmez yazılımcılardan kaynaklandığını düşünüyorum) ve müdahale etmemiz gerekebilir.
Bu makalemizin konusunu da, bu tür hatalı biçimde gelen sayılarla nasıl işlem yapılacağı oluşturmaktadır.

Excel'e X bir programdan veri aktarımı yaptım ve aşağıdaki gibi bir sonuç aldım:

metin biçimindeki sayılar


Eğer aktarım sonrasında, Excel sayfanızdaki sayılar, üst resimde ok ile işaretlediğim alandaki gibiyse, Excel bu sayıları ne yazık ki Metin (Text) biçiminde görmektedir.

Metin biçimindeki sayılarınızla, hiç bir şekilde matematiksel işlem (toplama, çıkarma, çarpma, bölme vs) yapamazsınız.
Peki bu tür işlemleri yapabilmek için ne yapmanız gerekir?

İlk olarak; bu sayıları aşağıdaki resimde göreceğiniz şekilde Sayı (Number) biçimine dönüştürebilirsiz. Bu yöntem en garanti olup, ilk önereceğim yöntemdir.

metin biçiminde sayılar


Peki alternatif olarak neler yapabiliriz?

Önce, boş bir Excel hücresine 1 yazıyoruz ve 1 rakamını yazdığımız hücreyi Ctrl + C tuşuna basarak kopyalıyoruz.

kopyala


Hücrenin kopyalanmış olduğundan emin olmamız gerekir (etrafındaki kesik çizgilerin olduğundan emin olun)

Daha sonra, sayılarımızın olduğu alanı seçiyoruz.

alanı seçme


Üstte görüleceği üzere 1 rakamının olduğu hücre yapıştırmaya hazır modda.

3. adımda, alan seçiliyken farenin sağ tuşuna basıyoruz ve Özel Yapıştır seçeneklerini seçiyoruz.

özel yapıştır


Özel Yapıştır'ı tıkladıktan sonra karşımıza çıkacak olan aşağıdaki resimde görüleceği seçenekleri işaretleyip, tamam dedikten sonra artık Metin biçimindeki sayılarımız, işlem yapabileceğimiz şekilde Sayı biçimine dönüşmüş oldu.



Son olarak bu işlemlerle uğraşmadan, formül oluşturarak bu sayıları toplamak isterseniz;
=TOPLA.ÇARPIM((B5:B13<>"")*(B5:B13)) formülünü yazmanız yeterli olacaktır.

Yararlı olması temennisiyle.
 
Üst