Soru Yan yana olan sütunlarda aynı olan rakam adedini hesaplama

Mr. Dijital

New member
Üye
#1
Merhabalar,

A (2014 Yılı) B (2015 Yılı) C (2016 Yılı) ve D (2017 Yılı) sütunlarımız var ve bu sütunlarda rakamlar var. Örneğin bu rakamlar telefon numaraları olsun. Sütunların altında farklı sayılarda telefon numaraları olduğunu ve aynı sütun içerisinde de birden fazla aynı telefon numaralarının olabileceğini düşünelim.

Ben E sütununda 1 telefon numarasının geçmiş yıllara bakarak kaç tane olduğunu hesaplamak istiyorum. Mesela her telefon numarası benim o yıl içerisinde ürünümü satın alan bir müşteri ise, bu müşterinin sadakatini görmek için, benden her yıl ürün alıyor mu görmek istiyorum.

Örnek sonuçlar şöyle olacak, 555 111 33 22 numarasının karşısında 4 yazıyorsa, 4 yıl da benden ürün aldığını; 3 yazıyorsa benden 4 yıl içerisinde farklı yıllarda olmak üzere 3 yıldır ürün aldığımı anlamalıyım.

İnşaallah anlatabilmişimdir.

Şimdiden teşekkür ederim.
 

OrkmesB

Administrator
Yönetici
Admin
#2
Merhabalar,

A (2014 Yılı) B (2015 Yılı) C (2016 Yılı) ve D (2017 Yılı) sütunlarımız var ve bu sütunlarda rakamlar var. Örneğin bu rakamlar telefon numaraları olsun. Sütunların altında farklı sayılarda telefon numaraları olduğunu ve aynı sütun içerisinde de birden fazla aynı telefon numaralarının olabileceğini düşünelim.

Ben E sütununda 1 telefon numarasının geçmiş yıllara bakarak kaç tane olduğunu hesaplamak istiyorum. Mesela her telefon numarası benim o yıl içerisinde ürünümü satın alan bir müşteri ise, bu müşterinin sadakatini görmek için, benden her yıl ürün alıyor mu görmek istiyorum.

Örnek sonuçlar şöyle olacak, 555 111 33 22 numarasının karşısında 4 yazıyorsa, 4 yıl da benden ürün aldığını; 3 yazıyorsa benden 4 yıl içerisinde farklı yıllarda olmak üzere 3 yıldır ürün aldığımı anlamalıyım.

İnşaallah anlatabilmişimdir.

Şimdiden teşekkür ederim.
Örnek bir dosya eklerseniz üzerinden daha rahat gideriz.


Tapatalk kullanarak iPhone aracılığıyla gönderildi
 

OrkmesB

Administrator
Yönetici
Admin
#6
Daha kısaltılabilir belki ama hızlıca aşağıdaki formül işinizi görebilir:

Kod:
=SUM(IF(COUNTIF($B$2:$B$47;$F2)>1;1;COUNTIF($B$2:$B$47;$F2));IF(COUNTIF($C$2:$C$47;$F2)>1;1;COUNTIF($C$2:$C$47;$F2));IF(COUNTIF($D$2:$D$47;$F2)>1;1;COUNTIF($D$2:$D$47;$F2));IF(COUNTIF($E$2:$E$47;$F2)>1;1;COUNTIF($E$2:$E$47;$F2)))
G2 hücresine yazıp aşağı çekin bakalım.

Fonksiyonların Türkçe karşılıkları:
SUM = TOPLA
IF = EĞER
COUNTIF = EĞERSAY
 

tugkan

Moderator
Yönetici
Moderatör
#7
Merhaba,
Yıllar içindeki tekrarlar önemsiz dediğiniz için her bir yılın içindeki tekrar eden numaraları kaldırdım(VERİ=>YİNENELENLERİ KALDIR)
Daha sonra ise G sütununa EĞERSAY formülünü uyguladım.
Daha pratik çözümü olan arkadaşlar vardır.
 

Ekli dosyalar

Mr. Dijital

New member
Üye
#8
Merhaba,
Yıllar içindeki tekrarlar önemsiz dediğiniz için her bir yılın içindeki tekrar eden numaraları kaldırdım(VERİ=>YİNENELENLERİ KALDIR)
Daha sonra ise G sütununa EĞERSAY formülünü uyguladım.
Daha pratik çözümü olan arkadaşlar vardır.
buradaki formül yanlış. bu formül tüm datayı sayıyor. Halbuki 1 yıldaki aynı sayılar bizim için 1 sayılıyor.
 

Mr. Dijital

New member
Üye
#9
sonuç vermedi üstad

Daha kısaltılabilir belki ama hızlıca aşağıdaki formül işinizi görebilir:

Kod:
=SUM(IF(COUNTIF($B$2:$B$47;$F2)>1;1;COUNTIF($B$2:$B$47;$F2));IF(COUNTIF($C$2:$C$47;$F2)>1;1;COUNTIF($C$2:$C$47;$F2));IF(COUNTIF($D$2:$D$47;$F2)>1;1;COUNTIF($D$2:$D$47;$F2));IF(COUNTIF($E$2:$E$47;$F2)>1;1;COUNTIF($E$2:$E$47;$F2)))
G2 hücresine yazıp aşağı çekin bakalım.

Fonksiyonların Türkçe karşılıkları:
SUM = TOPLA
IF = EĞER
COUNTIF = EĞERSAY
33333.JPG
 

OrkmesB

Administrator
Yönetici
Admin
#10
Vermez çünkü Türkçe Excel kullanıyorsunuz :)
Mesajımı tam okumadan test etmişsiniz hocam.
Bir üst mesajımı tekrar ve dikkatlice okuduğunuzda sorunu çözmüş olacaksınız muhtemelen.
 

tugkan

Moderator
Yönetici
Moderatör
#11
=TOPLA(EĞER(EĞERSAY($B$2:$B$47;$F2)>1;1;EĞERSAY($B$2:$B$47;$F2));EĞER(EĞERSAY($C$2:$C$47;$F2)>1;1;EĞERSAY($C$2:$C$47;$F2));EĞER(EĞERSAY($D$2:$D$47;$F2)>1;1;EĞERSAY($D$2:$D$47;$F2));EĞER(EĞERSAY($E$2:$E$47;$F2)>1;1;EĞERSAY($E$2:$E$47;$F2)))
 

alpadem

New member
Üye
#15
Merhabalar Ustalarımızın komplike formülleri gibi olmaz ama naçizane kaba bir formülde şu şekilde olabilir belki

=+EĞERSAY($B$2:$B$100;$F2)+EĞERSAY($C$2:$C$100;$F2)+EĞERSAY($D$2:$D$100;$F2)+EĞERSAY($E$2:$E$100;$F2)
 

Ekli dosyalar

alpadem

New member
Üye
#16
Merhabalar Ustalarımızın komplike formülleri gibi olmaz ama naçizane kaba bir formülde şu şekilde olabilir belki

=+EĞERSAY($B$2:$B$100;$F2)+EĞERSAY($C$2:$C$100;$F2)+EĞERSAY($D$2:$D$100;$F2)+EĞERSAY($E$2:$E$100;$F2)
@OrkmesB Üstadın formülü doğru çalışıyor çünkü siz aynı yıl içinde birden fazla "322" yazsanız bile o yıldaki "322" değerini 1 saymasını istemişsiniz. Ancak anladığım kadarıyla kaç kere geçtiğini de saymak istiyorsunuz, ondan yukarıda formülü yazdım, yoksa Bahadır Örkmes hocamın formülü doğrudur.
 

alpadem

New member
Üye
#17
@OrkmesB Üstadın formülü doğru çalışıyor çünkü siz aynı yıl içinde birden fazla "322" yazsanız bile o yıldaki "322" değerini 1 saymasını istemişsiniz. Ancak anladığım kadarıyla kaç kere geçtiğini de saymak istiyorsunuz, ondan yukarıda formülü yazdım, yoksa Bahadır Örkmes hocamın formülü doğrudur.
Belki hocamın formülü basitleştirmek adına şu şekilde kullabilirsiniz;

=TOPLA(EĞER(EĞERSAY($B$2:$B$47;$F2)>=1;1;0);EĞER(EĞERSAY($C$2:$C$47;$F2)>=1;1;0);EĞER(EĞERSAY($D$2:$D$47;$F2)>=1;1;0);EĞER(EĞERSAY($E$2:$E$47;$F2)>=1;1;0))
 

OrkmesB

Administrator
Yönetici
Admin
#18
"Değilse 0 olsun" kısmında bir problem olmuştu, o yüzden o kısma da tekrar eğersay kullandım diye aklımda kaldı hocam.
 
Üst